Back to overview
Downtime

Melody Is Experiencing an Outage

May 30, 2022 at 01:01am UTC

Resolved
May 30, 2022 at 03:18pm UTC

The issue has been resolved.

Created
May 30, 2022 at 01:01am UTC

We’re currently experiencing an issue with Melody connecting to discord.